(Lack of) Quality, Meade to Order

This is the tale of my wonderful paperweight 8″ Meade LX90 ACF. It isn’t my usual astrophotography-related blog, but I think that it’s really something that should be put out there nonetheless as it applies to equipment that some reader may consider purchasing in the future. But keep in mind, this is merely MY personal experience. Yours may vary. But quick Google searches on this issue will return a myriad of similar experiences people have had with Meade Instruments over the years.

It all started about 3 years ago. I decided I wanted a nice 8″ go-to scope, as my 6″ reflector and rickety EQ mount just weren’t cutting it. I had decided on an Schmidt-Cassegraine of some flavour. So after a lot of looking around, I settled on the LX90 ACF that was in my price range. It seemed like the optics were awesome even though reviews on the mount were mixed. People seemed to love it for visual, but hated it for photography. And it seemed some of the heavy users were encountering some problems with motors and electronics and having issues with Meade tech support and getting their mounts repaired. I spoke to a few people and they recommended going Celestron instead, but for a comparable Celestron at the time, I was looking at several hundred dollars more than I was willing to spend. I figured I was going to use this for visual observing only (hadn’t gotten into photography yet), and figured I’d get a wedge if I ever wanted to take pics. So I placed my order.

In the first 2 years I owned it, life happened. I didn’t manage to get out with it more than a dozen times or so at most. And for what I did, it seemed great. I was having occasional tracking problems on the azimuth axis, but it was minor and not really much of an issue for visual observation. It wasn’t until last summer that I started encountering more serious problems. Note that despite being over 2 years old, it had seen little use and great care, had always been stored in its shipping box, etc. So for all intents and purposes, this was mint condition scope with hardly any use, despite being out of warranty.

Last summer, I started with photography. For the most part, the scope worked fine. I was taking short, 30 second exposures only, so field rotation wasn’t an issue. Most of the time, it tracked perfectly, but occasionally it would drift on the azimuth axis. But minor issues overall. Then it got worse. Occasionally, the azimuth motor would stop altogether. It would be in mid-slew, and just stop. The altitude axis always worked fine, but azimuth would die. I would have to kill the power, re-align, and it would be good for a while. I called Meade about this, and they had no answers for me, claiming they’d never seen this problem before. They suggested I send it to them to look at it, but since the scope was out of warranty, I was looking at a hefty bill just to get it looked at, not to mention shipping costs.

Then it happened… One day, I powered it up, and got a “Motor Fault” error. I called Meade. Again, since it was out of warranty, they seemed very disinterested in helping me over the phone. The best they could do was tell me to ship it to them. I found that switching it on and off a few times would eventually correct the error and it would continue working “normally” (I use that term loosely) for a while before the motor would give out again.

In June of this year, I once again got the “Motor Fault” error, and it was permanent this time. Over several days, I messed with it, tried different power supplies, batteries, etc, but to no avail. The motor wasn’t working any more. So I called Meade again, knowing I’d have to bite the bullet and send it in. After a brief conversation with a disinterested employee who barely spoke English, he told me I would be charged $300 + shipping costs both ways for repair. Left without any options, I sent it off to them.

That’s when the fun started. The shipping cost was $140 to get it to them. About a week later, I received a call from Purolator. US Customs tacked on a $220 customs fee on the scope, despite it being declared as a warranty return and having an RMA number from Meade listed on the box. Of course, Meade wouldn’t accept deliver of the scope with customs owed. Purolator informed me of my options; I had to either pay the customs fees, pay return shipping (plus customs for re-entry into Canada) or forfeit the package. So naturally, I had to pay it.

About two weeks ago, I was thrilled to come home from work to find a UPS slip in my mail box. Not so thrilled to see $120 customs fees owing on it, but happy to have my “working” scope back. Unpacking it, I saw that they charged my credit card $375 for repair and return shipping. Unfortunately, it was cloudy and rainy for a week straight after, so I couldn’t actually test it. But finally the following weekend, I had a nice clear night!

I got all set up in my yard. I powered up the scope, and “Motor Fault”. You gotta be kidding me! After turning it on and off a few times, finally it kicked in. But the GPS receiver was no longer working. I went into the menu to enable it, but it was already turned on. So basically, they broke my GPS while “fixing” the scope. It would hang while attempting to access the GPS. I did have my local coordinates saved previously, so I was able to call that up and get the alignment done. I was able to start using it. I slewed to a few objects. Tracking seemed as hit or miss as before. But it was working more or less.

Then in mid-slew, the azimuth motor stopped working. I had to reset it again several times to get it working due to the motor fault error. Finally, I gave up, determined to call Meade again the next day. Needless to say, I was furious. I’d just paid well over $700 to get the scope fixed, and it still didn’t work. I could have just gotten a new 8″ LX80 ACF tube on a dovetail (same OTA as the LX90) to mount on my EQ mount for the price I had paid to fix this thing, and it was actually in worse condition now than when I’d sent it to them.

Over the next few days, I called Meade twice. Each time, a guy took my info and told me a tech would call me right back. No one called me back. When I called the second time, I made it quite clear to the guy on the phone I was furious at the amount of money I had paid only to have the scope shipped back in worse condition than I sent it. His best advice was to ship it back to them (again at my own expense) so they could look at it again, and that someone would call me back shortly. I waited another 2 days, and got no call. So I proceeded to go to the Meade Facebook page and made an angry post detailing my experience.

Finally I got their attention! The following day, I got a call from the head of Meade’s customer service department about the Facebook post. He was very apologetic and told me they’d immediately be crediting the repair costs back to my credit card, but I was out of luck when it came to shipping and customs expenses (which were double the repair bill). He offered to take the scope back completely at Meade’s expense, this time – including shipping and customs expenses – and look at it again. He wanted to “make it right”. He even offered to take the scope home and personally test it outdoors in actual practical use instead of on the bench in the shop to try to get to the root of the problem

As much as he wanted to “make it right”, at this point, nothing short of refunding me in full for the scope is going to make this anywhere near right. The frustration, headaches, and incredible expense required to get what’s supposed to be a “premium quality” instrument to function had taken its toll on me. Even if they had offered a full refund, I’d still be out a lot of money from the shipping and customs fees. And at this point, I had made a decision. I had already removed the OTA from the fork mount and ordered some tube rings and a dovetail to mount it on my Celestron Advanced VX EQ mount so I could actually use my OTA problem-free. I can vouch for top quality optics in that scope and I love it, but I have zero confidence in the quality of the mount or the service and support from Meade.

It’s unfortunate it took me publicly posting a scathing review of what went down on Facebook before they’d get back to me. Had they gotten back to me before that, I may have been inclined to accept their offer to take it back at their expense. To me, charging me a bunch of money and not having repaired it in the first place and their subsequent inaction in calling me back showed disrespect for me as a customer. And if I’m dropping thousands of dollars for a premium instrument, I expect it to work right and to actually be treated like a valued customer, not just another source of cash flow.

So I can officially say that I’m done with Meade. I’ll continue enjoying my OTA on my Celestron mount. But as far as I’m concerned, the LX90 mountĀ itself is rubbish and has been demoted to paper weight status. The next time I have a few thousand dollars to spend on a scope, I most certainly will NOT be looking in Meade’s direction.

I should be receiving my rings and dovetail plate in the next week or so, and I’ll post a followup (and hopefully some images) once I can get out to test the new setup.

Until then, clear skies!